Joomla!-Systemvoraussetzungen – Joomla Requirments

Joomla-Systemvoraussetzungen / Requirements  von Version 1  / 1.5 / 1.6 / 1.7 / 2.5 / 3.x bis heute in tabellarischer Form

 

Heute kommen durch die hacker immer wieder die Provider ins Schwitzen und drängen die Kunden die PHP / MySQL Versionen in Ihren CMS System anzupassen bzw. dieses up zu daten. Doch das ist oft garnicht so einfach, da das ja in der Regel mit Zeit / Arbeit also mit Geld verbunden ist. Hier die wichtigsten Bedingungen die einzuhalten sind, da sonst die Joomla Version Probleme macht.

es sollten definitiv keine Joomla Version 1.0 installiert sein, da diese größte probleme bereiten kann. Um diesem Umstand rechnung zu tragen unterstützen nur noch einige diese alte PHP und MySQL version. So das der Kunde an sich so wie so ein Upgrade machen muss. Bei 1und1 zahlt mal monatlich extra Gebühren um eine ältere PHP Version vorzuhalten. Das wird auf Dauer teuer und man kann keine aktuellen Extentions verwenden! Deshalb mein Rat: Verwenden Sie immer die aktuelleste Version von Joomla und den Servertools des Provider, dann sind sie an sich sicher vor Hacker! Wenn Sie mit uns zum Beispiel einen kleinen CMS Wartungsvertrag beauftragen, werden wir in regelmässigen Abständen ihr CMS bzw. PHP / MySQL upgraden und bei Bedarf Ihnen mitteilen, welche weiteren Schritte notwendig sind.

Voraussetzungen für Joomla! 3.x

Software Empfohlen Minimum Mehr Information
PHP 5.6 oder 7.0 + 5.3.10 + http://www.php.net
MySQL (InnoDB Support!) 5.5.3 + 5.1 http://www.mysql.com
MS SQL Server 10.50.1600.1 + 10.50.1600.1 http://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 http://www.postgresql.org
Apache
(mit mod_mysql, mod_xml,
und mod_zlib)
2.4 + 2.0 http://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS 7 7 http://www.iis.net

Voraussetzungen für Joomla! 1.6.x / 1.7.x / 2.5.x

Software Empfohlen Minimum Mehr Information
PHP max 5.4+ 5.2.4+ http://www.php.net
MySQL 5.0.4 + 5.0.4 + http://www.mysql.com
Apache
(mit mod_mysql, mod_xml,
und mod_zlib)
2.x + 2.x + http://www.apache.org

Voraussetzungen / Requirements für Joomla! 1.5.x

Software Empfohlen Minimum Mehr Information
PHP 5.2+ 4.3.10 http://www.php.net
MySQL 4.1.x + 3.23 http://www.mysql.com
Apache
(mit mod_mysql, mod_xml,
und mod_zlib)
2.x + 1.3 http://www.apache.org
Voraussetzungen / Requirements für Joomla! 1.0

Kein Support seit 22 Juli 2009

Software Empfohlen Minimum Mehr Information
PHP 5.3 4.2 https://secure.php.net
MySQL 4.1.x + 3.23 https://www.mysql.com
Apache
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 1.3 https://www.apache.org
Microsoft IIS 7 6 https://www.iis.net

Die aktuelle Joomla Version ist Joomla 3.6.4 (Stand November 2016).

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.